[FYI] php ver 5.2.4 って

PHP ver 5.2.4 が公開されました。
が、これコンパイルオプションが大幅に変わっている模様。

今までのコンパイルオプションでコンパイルしようとすると、

Notice: Following unknown configure options were used:

–with-apache2=../httpd-2.2.4
–enable-mbstr-enc-trans
–enable-track-vars
–with-xml
–with-dom
–with-dom-xslt
–with-dom-exslt
–with-sablot
–enable-xslt
–with-xslt-sablot

こんなエラーが出る。
php 5.2.3 ではこのオプションはサポートされている。
どうやらdom関連はデフォルトでONになってるらしく、逆に使わない時は disable しないといけないらしい。
コンパイルが通らなくなって焦りました。

自分がよく使うコンパイルオプションは以下。

./configure \
–prefix=/usr/local/php \
–with-config-file-path=/usr/local/php/lib/ \
–with-apxs2=/usr/local/apache/bin/apxs \
–with-mysql=/usr/local/mysql \
–enable-mbstring \
–enable-mbstr-enc-trans \
–enable-mbregex \
–with-openssl \
–enable-track-vars \
–enable-zend-multibyte \
–with-xml \
–with-zlib \
–with-dom \
–with-dom-xslt \
–with-dom-exslt \
–with-sablot \
–enable-xslt \
–with-xslt-sablot \
–with-gd \
–with-freetype \
–with-freetype-dir=/usr/local/include/freetype2/freetype \
–with-png \
–with-jpeg \
–with-tidy

[FYI] php ver 5.2.4 って」に1件のコメントがあります

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください