CentOS 6.3 + memcached + PHPにて


memcached 1.4.7 をインストールすべく。

memcached-1.4.7-1.el6.rfx.x86_64
memcached-devel-1.4.7-1.el6.rfx.x86_64

上記ファイルを取得してrpmでインストール。
php に memcached.so を入れる際、以下のコマンドを利用。

/usr/local/php/bin/pecl install -a memcached

libmemcached のライブラリが ver 1.0 以上じゃないとコケます。
自分はそこまでは簡単に判ったんですが、 libmemcached-1.0.10 のインストール時に
コケまくりました。
原因は libevent-devel が入ってなかったので、event.h が no such file になりまして。

昔同様のトラブルがあったのですが、すっかり忘れてました。

コメントを残す

メールアドレスが公開されることはありません。